Author Topic: Can't change keyboard language  (Read 11075 times)

Antigaprime

  • Newbie
  • *
  • Posts: 28
    • View Profile
Can't change keyboard language
« on: June 06, 2012, 08:38:55 AM »
Hi, I've been having trouble changing the keyboard language in Youwave. After following the steps to change the language, after restarting Youwave, the language only stays put for a couple of minutes at best, and sometimes doesn't even change at all. I also noticed that I have a new language in my windows system (English - US keyboard layout), and even after deleting this setting in the Regional and Language settings in windows, it will be back every time I open Youwave, which is already starting to get annoying. Anyone know how to solve this?

YouWaveAdmin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1222
    • View Profile
Re: Can't change keyboard language
« Reply #1 on: June 09, 2012, 11:44:03 PM »
This is by an intriguing design. The Windows language for YouWave is English. And then on the Android side, the language is changed to another language.

What is the exact issue you are facing? Some task that you'd like to do but could not?
YouWave is updated to Android Lollipop. See youwave.com/download

Antigaprime

  • Newbie
  • *
  • Posts: 28
    • View Profile
Re: Can't change keyboard language
« Reply #2 on: June 10, 2012, 06:35:23 AM »
The problem is that I don't want the English (US keyboard) layout. I'm accustomed to the Spanish layout, which for some reason in the new 2.2.3 version, keeps getting changed to English, and therefore certain characters are now in different places, which isn't really a problem, but is incredibly annoying.

Spitfire

  • Newbie
  • *
  • Posts: 42
  • «The Fire King»
    • View Profile
    • «El Diario de un Cruzado» v1.4
Re: Can't change keyboard language
« Reply #3 on: June 11, 2012, 08:05:14 PM »
It happens since 2.2.2 I think.

Try the following:

1) Start YouWave.
2) Change Keyboard Layout.
3) Close YouWave.
4) Start YouWave again.

If it's still with the layout problem, re-install the application... or start from zero again:

1) Go to %USERPROFILE%/.VirtualBox/HardDisks/
2) Delete "youwave_vm01.vdi"
3) Copy "youwave_vm01_golden.vdi" and Paste it in the same folder.
4) The "youwave_vm01_golden.vdi" copy rename it to "youwave_vm01.vdi".

That's how you do a fresh start in YW.
Good luck.

Antigaprime

  • Newbie
  • *
  • Posts: 28
    • View Profile
Re: Can't change keyboard language
« Reply #4 on: June 11, 2012, 10:31:28 PM »
It happens since 2.2.2 I think.

Try the following:

1) Start YouWave.
2) Change Keyboard Layout.
3) Close YouWave.
4) Start YouWave again.

If it's still with the layout problem, re-install the application... or start from zero again:

1) Go to %USERPROFILE%/.VirtualBox/HardDisks/
2) Delete "youwave_vm01.vdi"
3) Copy "youwave_vm01_golden.vdi" and Paste it in the same folder.
4) The "youwave_vm01_golden.vdi" copy rename it to "youwave_vm01.vdi".

That's how you do a fresh start in YW.
Good luck.

Tried that, and it's no use. It seems to be working with the correct keyboard layout right now, but I'm not sure how long it will last, I don't feel like reinstalling youwave and having to start everything from scratch. I don't think a keyboard layout change should warrant a reinstall.

stonee

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Can't change keyboard language
« Reply #5 on: June 19, 2012, 01:56:00 AM »
Dear YouWave-Team

I'm using the (new) german keyboard layout you released in Version 2.2.1 (there was an older one with some mistakes in 2.2.0...)

Unfortunately, it keeps on resetting the "correct" keyboard layout to the old buggy one.
I always have to choose the "German Keyboard Layout" in the settings again, and then, it works after a Youwave-Reboot. But typically after rebooting the whole computer, it resets the layout back to the old one.

Is this the same problem as mentioned above, and maybe also the same solution?
Can I keep on using my current youwave-HD-file (youwave_vm01.vdi) after resetting the youwave_vm01_golden.vdi?

Best regards, thanks for your efforts

Daniel

Antigaprime

  • Newbie
  • *
  • Posts: 28
    • View Profile
Re: Can't change keyboard language
« Reply #6 on: June 21, 2012, 04:54:01 AM »
In case anyone is interested I figured out that in my particular case, given that when Youwave starts up Windows creates an additional Keyboard Setting in English US layout. I kept mistakenly changing it to Spanish, which is the layout I use both in Windows as in Youwave. It turns out that that is the reason why the layout in Youwave was getting messed up. Don't ask me why, but for the correct layout to work in Youwave, the keyboard layout in Windows should be set to English US.

In my case I make sure that when Youwave is focused the active windows keyboard layout is English US, and it works fine with the proper layout that is set inside Youwave.

@Stonee: I don't know if this might help you, but check if your Windows is creating another Keyboard Layout when Youwave starts; if it doesn't maybe you can try adding one with the layout in English US. I assume you use a German keyboard layout in Windows, so if this is the case, just make sure that when you focus the input to Youwave you change the Windows input language to English US, and see if it solves your issue.

Also, if you reset your VDI file you will lose everything, unless you make a backup. I suggest you don't since in this scenario reinstalling/resetting most likely won't fix anything.

YouWaveAdmin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1222
    • View Profile
Re: Can't change keyboard language
« Reply #7 on: June 25, 2012, 11:12:15 PM »
Antigaprime,

   Your observation is correct. Due to a technical limitation, the current YouWave Keyboard behavior is this: for the Android keyboard setting for the supported languages to work, the YouWave's focus window's keyboard layout should be English US (the software will set it automatically). By doing so, the software translates the keys to the respective languages.

   This is not an optimal solution as it confuses users, although it works. We are seeking a better solution which does not require setting the main window's keyboard layout to English US.
YouWave is updated to Android Lollipop. See youwave.com/download